Frequently Asked Questions

What do you mean with 1-year membership?

Every extension comes with a 1-year subscription, this means that during this 12 months you'll be able to download the latest version and ask for support at any time.

What payment methods do you accept?

We currently accept payments with PayPal, iDEAL, Mister Cash, Sofortüberweisung.de/DirectEbanking.
If you have a credit card you can still pay via the Paypal connection without having to get a Paypal account.

What happens when the subscription expires?

If your membership expires, you can continue to use the extensions you have downloaded during your membership period. However you will not be able to access new releases, updates and support.

How can I renew / upgrade my subscription?

After receiving an expiration e-mail that notifies you of the fact that your subscription expires in in a few days, all you have to do is go to "my subscriptions" and click the renew button . You'll also receive a 25% discount when you renew before your subscription expires. Your new subscription will start when your current subscription expires, so no days will be lost!

I paid for a subscription but haven’t received any download link yet

Normally, our system links the new subscription to your account automatically after a successful payment.
Though rarely, it could happen that your payment is not succesfull or your payment gateway sends the wrong information, in which case we will have to complete the process manually.
Please check your BULK/SPAM e-mail folders first and contact us if you haven’t received anything. We'll solve the issue as soon as possible.

Can I install the extension on multiple domains?

Yes, you can install any extension on as many domains as you want.

Can I access and customize the extension's code?

Of course. The extensions are fully open source and the code is NOT encrypted.
However, if you alter the extension files we can no longer provide support on any problem you encounter. Also, if you update or reinstall the extension, all changes you made will be lost.

Do you still support Joomla! 1.5?

No, there are some extensions that also have a J!1.5 version but we stopped updating them on November 2012.